Resources For Our Sage Clients

Everything you needed to know about Sage.

Sage 300 - System Requirements By Version

The following is a list of Sage 300 system requirement recommendations intended to cover all information regarding the compatibility of various operating systems and hardware. You should assume that any operating system not listed in these guides is incompatible with the current version of Sage.

If you are interested in other earlier versions system requirements for ACCPAC 6.0 and earlier please contact us and we would be happy to assist with any inquiries.

Sage HRMS - System Requirements By Version

The following is a list of Sage HRMS system requirement recommendations intended to cover all information regarding the compatibility of various operating systems and hardware. You should assume that any operating system not listed in these guides is incompatible with the current version of Sage.

Sage 300 - "What's New Guide" By Version

If you are running an earlier version of Sage 300 (Accpac) and interetsed in upgrading to the latest version? We will provide an upgrade quote with no obligations. Contact us today.


I was familiar with the flexibility of the Sage 300 ERP product and confident in the business process knowledge that Equation Technologies brought to the table.

Alex Eng - Controller - MD7

Need Help Now?

 866.436.3530   Request a Call